Ubuntu编译Python3
本文最后更新于 485 天前,其中的信息可能已经有所发展或是发生改变。

由于种种问题,需要用到Python3.7,而电脑上的还是Python3.5,于是就手动编译了一下,这篇文章主要是记录一下遇到的问题和相应的解决方案

编译安装

参考:https://blog.csdn.net/qq_29837161/article/details/83616364

主要就是设置一下安装目录(我装在了 /usr/local/python3.7 ),以及安装完之后 python3pip3 的软连接

./configure --prefix=/opt/python3.7
make install

问题

问题1:shell内乱码

解决方法:安装 readline 库: sudo apt-get install libreadline6 libreadline6-dev

然后注释掉源码中 Modules\Setup 中的这一行

#readline readline.c -lreadline -ltermcap

重新编译安装即可

问题2:lzms

运行时出现如下警告

UserWarning: Could not import the lzma module. Your installed Python is incomplete

解决方法:安装对应库,sudo apt-get install liblzma-dev

重新编译安装

暂无评论

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇